Print this page
1681 support for BUILD64=# no longer works
Split |
Close |
Expand all |
Collapse all |
--- old/usr/src/pkg/manifests/system-zones.mf
+++ new/usr/src/pkg/manifests/system-zones.mf
1 1 #
2 2 # CDDL HEADER START
3 3 #
4 4 # The contents of this file are subject to the terms of the
5 5 # Common Development and Distribution License (the "License").
6 6 # You may not use this file except in compliance with the License.
7 7 #
8 8 # You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
9 9 # or http://www.opensolaris.org/os/licensing.
10 10 # See the License for the specific language governing permissions
11 11 # and limitations under the License.
12 12 #
13 13 # When distributing Covered Code, include this CDDL HEADER in each
↓ open down ↓ |
13 lines elided |
↑ open up ↑ |
14 14 # file and include the License file at usr/src/OPENSOLARIS.LICENSE.
15 15 # If applicable, add the following below this CDDL HEADER, with the
16 16 # fields enclosed by brackets "[]" replaced with your own identifying
17 17 # information: Portions Copyright [yyyy] [name of copyright owner]
18 18 #
19 19 # CDDL HEADER END
20 20 #
21 21
22 22 #
23 23 # Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
24 +# Copyright 2014 Andrew Stormont.
24 25 #
25 26
26 27 set name=pkg.fmri value=pkg:/system/zones@$(PKGVERS)
27 28 set name=pkg.description \
28 29 value="Solaris Zones Configuration and Administration"
29 30 set name=pkg.summary value="Solaris Zones"
30 31 set name=info.classification value=org.opensolaris.category.2008:System/Core
31 32 set name=variant.arch value=$(ARCH)
32 33 dir path=etc group=sys variant.opensolaris.zone=global
33 34 dir path=etc/brand group=sys variant.opensolaris.zone=global
34 35 dir path=etc/zones group=sys variant.opensolaris.zone=global
35 36 dir path=lib variant.opensolaris.zone=global
↓ open down ↓ |
2 lines elided |
↑ open up ↑ |
36 37 dir path=lib/svc variant.opensolaris.zone=global
37 38 dir path=lib/svc/manifest group=sys variant.opensolaris.zone=global
38 39 dir path=lib/svc/manifest/system group=sys variant.opensolaris.zone=global
39 40 dir path=lib/svc/method variant.opensolaris.zone=global
40 41 dir path=usr group=sys
41 42 dir path=usr/bin
42 43 dir path=usr/kernel group=sys
43 44 dir path=usr/kernel/drv group=sys
44 45 dir path=usr/kernel/drv/$(ARCH64) group=sys
45 46 dir path=usr/lib
46 -dir path=usr/lib/$(ARCH64)
47 +$(BUILD64)dir path=usr/lib/$(ARCH64)
47 48 dir path=usr/lib/brand
48 49 dir path=usr/lib/brand/ipkg group=bin
49 50 dir path=usr/lib/brand/shared group=sys
50 51 dir path=usr/lib/zones
51 52 dir path=usr/sbin
52 53 dir path=usr/share
53 54 dir path=usr/share/lib
54 55 dir path=usr/share/lib/xml group=sys
55 56 dir path=usr/share/lib/xml/dtd group=sys
56 57 dir path=usr/share/man
57 58 dir path=usr/share/man/man1
58 59 dir path=usr/share/man/man1m
59 60 dir path=usr/share/man/man5
60 61 dir path=usr/share/man/man7d
61 62 driver name=zcons
62 63 file path=etc/zones/SUNWblank.xml mode=0444 variant.opensolaris.zone=global
63 64 file path=etc/zones/SUNWdefault.xml mode=0444 variant.opensolaris.zone=global
64 65 file path=etc/zones/index group=sys original_name=SUNWzone:etc/zones/index \
65 66 preserve=true variant.opensolaris.zone=global
66 67 file path=lib/svc/manifest/system/resource-mgmt.xml group=sys mode=0444 \
67 68 variant.opensolaris.zone=global
68 69 file path=lib/svc/manifest/system/zones.xml group=sys mode=0444 \
69 70 variant.opensolaris.zone=global
↓ open down ↓ |
13 lines elided |
↑ open up ↑ |
70 71 file path=lib/svc/manifest/system/zonestat.xml group=sys mode=0444 \
71 72 variant.opensolaris.zone=global
72 73 file path=lib/svc/method/svc-resource-mgmt mode=0555 \
73 74 variant.opensolaris.zone=global
74 75 file path=lib/svc/method/svc-zones mode=0555 variant.opensolaris.zone=global
75 76 file path=lib/svc/method/svc-zonestat mode=0555 \
76 77 variant.opensolaris.zone=global
77 78 file path=usr/bin/zonestat mode=0555
78 79 file path=usr/kernel/drv/$(ARCH64)/zcons group=sys
79 80 $(i386_ONLY)file path=usr/kernel/drv/zcons group=sys
80 -file path=usr/lib/$(ARCH64)/libbrand.so.1
81 -file path=usr/lib/$(ARCH64)/libzonecfg.so.1
82 -file path=usr/lib/$(ARCH64)/libzonestat.so.1
81 +$(BUILD64)file path=usr/lib/$(ARCH64)/libbrand.so.1
82 +$(BUILD64)file path=usr/lib/$(ARCH64)/libzonecfg.so.1
83 +$(BUILD64)file path=usr/lib/$(ARCH64)/libzonestat.so.1
83 84 file path=usr/lib/brand/ipkg/config.xml mode=0444
84 85 file path=usr/lib/brand/ipkg/platform.xml mode=0444
85 86 file path=usr/lib/brand/shared/common.ksh mode=0444
86 87 file path=usr/lib/brand/shared/query mode=0755
87 88 file path=usr/lib/brand/shared/uninstall.ksh mode=0444
88 89 file path=usr/lib/libbrand.so.1
89 90 file path=usr/lib/libzonecfg.so.1
90 91 file path=usr/lib/libzonestat.so.1
91 92 file path=usr/lib/zones/zoneadmd mode=0555
92 93 file path=usr/lib/zones/zonestatd mode=0555 variant.opensolaris.zone=global
93 94 file path=usr/sbin/zlogin mode=0555
94 95 file path=usr/sbin/zoneadm mode=0555
95 96 file path=usr/sbin/zonecfg mode=0555
96 97 file path=usr/share/lib/xml/dtd/brand.dtd.1 mode=0644
97 98 file path=usr/share/lib/xml/dtd/zone_platform.dtd.1 mode=0644
98 99 file path=usr/share/lib/xml/dtd/zonecfg.dtd.1
99 100 file path=usr/share/man/man1/zlogin.1
100 101 file path=usr/share/man/man1m/zoneadm.1m
101 102 file path=usr/share/man/man1m/zoneadmd.1m
102 103 file path=usr/share/man/man1m/zonecfg.1m
103 104 file path=usr/share/man/man5/brands.5
104 105 file path=usr/share/man/man5/zones.5
105 106 file path=usr/share/man/man7d/zcons.7d
106 107 legacy pkg=SUNWzoner desc="Solaris Zones Configuration Files" \
107 108 name="Solaris Zones (Root)"
108 109 legacy pkg=SUNWzoneu desc="Solaris Zones Configuration and Administration" \
109 110 name="Solaris Zones (Usr)"
110 111 license cr_Sun license=cr_Sun
111 112 license lic_CDDL license=lic_CDDL
112 113 link path=usr/bin/zonename target=../../sbin/zonename
↓ open down ↓ |
20 lines elided |
↑ open up ↑ |
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX